杭电2673(shǎ崽 OrOrOrOrz)
点击打开杭电2673
Problem Description Acmer in HDU-ACM team are ambitious, especially shǎ崽, he can spend time in Internet bar doing problems overnight. So many girls want to meet and Orz him. But Orz him is not that easy.You must solve this problem first.The problem is :
Give you a sequence of distinct integers, choose numbers as following : first choose the biggest, then smallest, then second biggest, second smallest etc. Until all the numbers was chosen .
For example, give you 1 2 3 4 5, you should output 5 1 4 2 3
Input There are multiple test cases, each case begins with one integer N(1 <= N <= 10000), following N distinct integers.
Output Output a sequence of distinct integers described above.
Sample Input
5 1 2 3 4 5
Sample Output
5 1 4 2 3
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
bool cmp(int a,int b)
{
if(a<b)
return 1;
else
return 0;
}
int main()
{
int n,i,j,k,a[10005];
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n,cmp);
for(i=0,j=n-1;i<n/2||j>=n/2;i++,j--)
{
if(j>=n/2)
{
if(j==n/2&&n%2!=0)
printf("%d\n",a[j]);
else
printf("%d ",a[j]);
}
if(i<n/2)
{
if(i==n/2-1&&n%2==0)
printf("%d\n",a[i]);
else
printf("%d ",a[i]);
}
}
}
return 0;
}
杭电2673(shǎ崽 OrOrOrOrz)
点击打开杭电2673
Problem Description Acmer in HDU-ACM team are ambitious, especially shǎ崽, he can spend time in Internet bar doing problems overnight. So many girls want to meet and Orz him. But Orz him is not that easy.You must solve this problem first.The problem is :
Give you a sequence of distinct integers, choose numbers as following : first choose the biggest, then smallest, then second biggest, second smallest etc. Until all the numbers was chosen .
For example, give you 1 2 3 4 5, you should output 5 1 4 2 3
Input There are multiple test cases, each case begins with one integer N(1 <= N <= 10000), following N distinct integers.
Output Output a sequence of distinct integers described above.
Sample Input
5 1 2 3 4 5
Sample Output
5 1 4 2 3
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
bool cmp(int a,int b)
{
if(a<b)
return 1;
else
return 0;
}
int main()
{
int n,i,j,k,a[10005];
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n,cmp);
for(i=0,j=n-1;i<n/2||j>=n/2;i++,j--)
{
if(j>=n/2)
{
if(j==n/2&&n%2!=0)
printf("%d\n",a[j]);
else
printf("%d ",a[j]);
}
if(i<n/2)
{
if(i==n/2-1&&n%2==0)
printf("%d\n",a[i]);
else
printf("%d ",a[i]);
}
}
}
return 0;
}